Bug Tracker

Modify

Ticket #7667 (closed bug: invalid)

Opened 3 years ago

Last modified 5 months ago

Umlaute

Reported by: liver@… Owned by:
Priority: undecided Milestone: 1.6
Component: unfiled Version: 1.4.4
Keywords: Cc:
Blocking: Blocked by:

Description (last modified by rwaldron) (diff)

Hello,

my name is Philipp Bürkner.

I have a problem but my english is very bad. I hope you are able to understand my language, german.

Ich habe versucht, mit dem folgenen Befehl einen Button neu zu beschriften. Hier ist der Code:

$('input[name="news_save"]').val("Löschen");

Leider wird aus dem ö kein ö. Ich habe auch schon folgendes ausprobiert:

$('input[name="news_save"]').val("Löschen");

Leider funktioniert das genau so wenig, weil dann das ö zum Kästchen wird.

Ich hoffe ihr habt eine Lösung dazu, da das ja mit JavaScript an sich geht. Nur möchte ich meine Webseite komplett mit jQuery gestalten, weil diese Datenbank wirklich gut gemacht ist und sehr nützlich ist.

Ich würde mich bei einer Rückmeldung sehr freuen.

Mit freundlichen Grüßen,

Philipp Bürkner.

I have tried to label with the following new command a button. Here's the code:

$ ('Input [name = "news_save "]'). val (" delete "); Unfortunately, the ö ö I have not even tried the following:

$ ('Input [name = "news_save "]'). val (" delete "); Unfortunately, just as little, because then the ö is the box.

I hope you have a solution to this, as indeed with the JavaScript is in itself. Only I would like to design my website complete with jQuery, because that database is really well done and very useful.

Change History

comment:1 Changed 3 years ago by rwaldron

  • Description modified (diff)

comment:2 Changed 3 years ago by jitter

  • Status changed from new to closed
  • Resolution set to invalid

Thanks for taking the time to contribute to the jQuery project by writing a bug report! But this isn't a bug in jQuery. The issue you experience is most likely caused by charset issues on your webpage. Check if the charset from the HTTP header and in the <meta> tag match. And if your code editor saves the js-file with the right encoding.

See this working test cases
 http://jsfiddle.net/rwaldron/Qus9j/4/
 http://jsfiddle.net/jitter/Usb6s/


Danke das du dir Zeit genommen hast deinen Beitrag zu jQuery zu leisten, indem du einen Bugreport verfasst hast. Das Problem das du hast ist aber kein Fehler in jQuery, sondern ist fast sicher von charset Problemen auf deiner Webseite verursacht. Wenn du dir die obigen Testfälle anschaust wirst du sehen das dort dieses Problem nicht auftritt. Passen charset im HTTP Header und im <meta> Tag auf der Seite zusammen? Speichert dein Editor die js-Datei mit der richtigen Kodierung ab? (Obige Testfälle verwenden z.B. durchgehend UTF-8).

Last edited 3 years ago by jitter (previous) (diff)

comment:3 Changed 5 months ago by Björn

Hello,

I think it is a Bug. I have the same Problems! Also in your Examples the Value "&ouml;" will be show instead of "ö", on the button.

Your Example  http://jsfiddle.net/rwaldron/Qus9j/4/ show on the Button "M&ouml;torhead" instead of "Mötorhead"

Same Problem I have with .prop()

$('input[name="save"]').prop("title","M&ouml;torhead");

The Title is also wrong

best regards

Björn

Please follow the  bug reporting guidlines and use  jsFiddle when providing test cases and demonstrations instead of pasting the code in the ticket.

View

Add a comment

Modify Ticket

Action
as closed
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.