Bug Tracker

Modify

Ticket #7659 (closed bug: worksforme)

Opened 3 years ago

Last modified 3 years ago

jQuery and Googlebot

Reported by: mr@… Owned by:
Priority: undecided Milestone: 1.6
Component: unfiled Version: 1.4.4
Keywords: needsreview Cc:
Blocking: Blocked by:

Description

jQuery seems to produce crawl errors with Googlebot. Google attempts to load the URL www.domain.com/a.

See this thread for more info:

 http://www.google.com/support/forum/p/Webmasters/thread?tid=4a93143097e77323&hl=en

Change History

comment:1 Changed 3 years ago by addyosmani

  • Status changed from new to closed
  • Resolution set to worksforme

Thank you for submitting a ticket to the jQuery Bug tracker!

Please note that as per what was mentioned near the end of the thread on the Google Webmasters support site, this issue is not present with jQuery 1.4.4 (you're using 1.3.2 which is quite old). If you update to the latest version of jQuery you'll find that this is no longer a problem.

comment:2 Changed 3 years ago by mr@…

If read the complete thread on the Google support site you will see that this bug still exists for jQuery 1.4.2 and 1.4.4.

comment:3 Changed 3 years ago by jitter

I don't think it's likely this is going to be fixed. The problem is the google-bot which is too smart for his own good by crawling js-files and then trying to find things which look like "obvious hidden links that are gonna be dynamically added to the page later". In this vain attempt it probably stumbles over  this line (so will still happen with 1.4.4) and thinks "oh there must be link url/a".

I guess you could fix this by adding a Disallow: /a to your robots.txt so that the google-bot finds the link but doesn't try to check if it leads somewhere.

Maybe it can be fixed on our side by slightly changing the string in this support test that it doesn't look like an obvious <a ..>..</a> anymore.

comment:4 Changed 3 years ago by jitter

  • Keywords needsreview added

A possible try for a fix on our side could be to add a rel="nofollow" to this link in the support test. That theoretically should stop the google-bot too (credits to DaveMethvin)

Another idea could be to change the href from /a to just / or # assuming IE normalizes those too.

Version 2, edited 3 years ago by jitter (previous) (next) (diff)

Please follow the  bug reporting guidlines and use  jsFiddle when providing test cases and demonstrations instead of pasting the code in the ticket.

View

Add a comment

Modify Ticket

Action
as closed
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.