Bug Tracker

Modify

Ticket #7657 (closed bug: duplicate)

Opened 3 years ago

Last modified 3 years ago

"cur" does not return negative numbers, that are less than "-10000"

Reported by: tsvetelina.ivanova@… Owned by:
Priority: low Milestone: 1.5
Component: effects Version: 1.4.3
Keywords: Cc:
Blocking: Blocked by:

Description

In case you want to animate an element, from position left:-11000, to position left:-12000, you will end up animating it from position left:0, to position left:-12000.

This is a result of a change in the method that gets the current CSS value (cur):

return r && r > -10000 ? r : parseFloat(jQuery.curCSS(this.elem, this.prop))
0;

changed to:

return r && r > -10000 ? r : 0;

I am trying to animate an element with a variable number of child elements to show each child element at a time. In case I have, for example, 12 child elements with width=1000px, animating from the 11th to the 12th will result in an incorrect animation.

Change History

comment:1 Changed 3 years ago by anonymous

Bug still present in 1.4.4 Please fix this.

comment:2 Changed 3 years ago by jitter

  • Status changed from new to closed
  • Resolution set to duplicate

comment:3 Changed 3 years ago by jitter

Duplicate of #7193.

comment:4 Changed 3 years ago by jitter

  • Priority changed from undecided to low
  • Component changed from unfiled to effects
  • Milestone changed from 1.6 to 1.5

Please follow the  bug reporting guidlines and use  jsFiddle when providing test cases and demonstrations instead of pasting the code in the ticket.

View

Add a comment

Modify Ticket

Action
as closed
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.