Bug Tracker

Ticket #7642 (closed bug: duplicate)

Opened 4 years ago

Last modified 3 years ago

jQuery behavior vith "application/xhtml+xml" mime type

Reported by: edoardo@… Owned by:
Priority: undecided Milestone: 1.6
Component: unfiled Version: 1.4.4
Keywords: Cc:
Blocking: Blocked by:

Description

First: I hope that I am not wasting your time, I apologize if this is a desidered behaviour.

The problem arises with "application/xhtml+xml" mime type if the page is serverd from a web server (Tomcat 7.0.4 in my tests).

1- if the page is serverd as testApplication.html [asking to Firefox for page informations the mime type is "text/html"] all goes well, a message appears inside the div.

2- if then page is served as testApplication.xhtml [asking to Firefox for page informations the mime type is "application/xhtml+xml"] and nothing appears inside the div.

the page code:


<?xml version="1.0" encoding="UTF-8" ?>
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">
<html xmlns="http://www.w3.org/1999/xhtml">
<head>
<title>Test</title>
<script src="https://ajax.googleapis.com/ajax/libs/jquery/1.4.4/jquery.min.js"></script>
<script>
    $(document).ready(function() {
        $( "<div/>" ).text( "test" ).prependTo( "#log" );
        $( "#log" ).attr( "scrollTop", 0 );
    });
</script>
</head>
<body>
    <p>Test area:</p>
    <div id="log" style="height: 200px; width: 300px; border :1px solid black"></div>
</body>
</html>

greetings Edoardo Panfili

Change History

comment:1 Changed 4 years ago by snover

  • Status changed from new to closed
  • Resolution set to duplicate

comment:2 Changed 4 years ago by snover

Duplicate of #6162.

Note: See TracTickets for help on using tickets.