Bug Tracker

Ticket #7584 (closed feature: wontfix)

Opened 4 years ago

Last modified 11 months ago

SVG support metaticket

Reported by: snover Owned by:
Priority: undecided Milestone: 1.next
Component: core Version: git
Keywords: Cc:
Blocking: Blocked by: #3116, #4705, #4850, #6007

Description

Metaticket for supporting SVG in jQuery Core.

Change History

comment:1 Changed 4 years ago by snover

  • Status changed from new to open
  • Blocked by 3116, 4705, 4850, 6007 added

comment:2 Changed 4 years ago by snover

  • Blocked by 4850 removed

comment:3 Changed 4 years ago by snover

  • Blocked by 4850 added

comment:4 Changed 4 years ago by jitter

  • Version set to git
  • Component changed from unfiled to core
  • Milestone set to 1.next

comment:5 Changed 4 years ago by john

  • Status changed from open to closed
  • Resolution set to patchwelcome

As it turns out, as revealed during the jQuery 1.6 roadmap discussion, we're having a hard time finding people that care about implementing the changes necessary to fix SVG support in jQuery - and in a way that continues to work fast.

I'm going to be closing this (and other SVG-related tickets) as "patchwelcome". If you're interested, and have a pull request, please feel free to re-open.

comment:6 Changed 4 years ago by timmywil

#8901 is a duplicate of this ticket.

comment:7 Changed 14 months ago by gavenkoa

FYI this page still live:  http://contribute.jquery.org/wont-fix/ (support issues with SVG/WML/etc).

comment:8 Changed 11 months ago by dmethvin

  • Status changed from closed to reopened
  • Resolution patchwelcome deleted

comment:9 Changed 11 months ago by dmethvin

  • Status changed from reopened to closed
  • Resolution set to wontfix

This ticket is being changed to wontfix since it isn't our intent to support SVG in any first-class way. The wontfix page will be updated shortly.

jQuery is an HTML DOM library and despite the fact that SVG uses a similar XML syntax it has different semantics. If you want to manipulate SVG a library like Raphael is more appropriate.

That said, we will still attempt to address issues *related* to SVG that appear outside the SVG document itself, such as events that bubble into HTML-land like #13180.

Note: See TracTickets for help on using tickets.