Bug Tracker

Ticket #7532 (closed bug: duplicate)

Opened 4 years ago

Last modified 3 years ago

jQuery 1.4.3 animation method behaves strangely when animated to left: over 10'000 px

Reported by: mail@… Owned by: mail@…
Priority: low Milestone: 1.5
Component: effects Version: 1.4.3
Keywords: animation left over 10000px Cc:
Blocking: Blocked by:

Description

Steps to reproduce:

  1. Create one huge container (mine is 12200 pixels wide)
  2. Fill it with images (to be more easy to observe the animation)
  3. Set it's position to relative
  4. Try to animate it to -10300 pixels

Expected behavior: animation is smooth and continuos

Observed: Container shakes strangely until reaching the desired left position.

Environment: All browsers (FF 3.6, IE 7+, Chrome)

jQuery versions: 1.4.3 and 1.4.4 . 1.4.2 works fine

I found this bug when creating a carousel with jcarousel plugin with 20 items, each one 606 pixels wide.

Change History

comment:1 Changed 4 years ago by addyosmani

  • Owner set to mail@…
  • Status changed from new to pending

This sounds very much like an issue with the actual code implementation rather than a problem caused by jQuery core.Could you please submit a valid test case on jsFiddle.net that reproduces your issue so we can investigate further?.

Last edited 4 years ago by addyosmani (previous) (diff)

comment:2 Changed 4 years ago by boushley

Alright, I took the time to put together a valid fiddle and things appear to work just fine.  http://jsfiddle.net/boushley/dgqsw/

Version 0, edited 4 years ago by boushley (next)

comment:3 Changed 4 years ago by addyosmani

  • Keywords animation left over 10000px added
  • Priority changed from undecided to low
  • Status changed from pending to closed
  • Component changed from unfiled to effects
  • Resolution set to worksforme

As boushley correctly points out this appears to be working fine. If you are doing something beyond what it in the above test case on jsFiddle and would like to re-open this ticket, please let us know.

comment:4 Changed 4 years ago by anonymous

Hi, I changed a bit the code in jsfiddle so now the bug reproduces properly. The left position now changes 606 pixels on click. So you have to click a couple of times. And animation easing changed to 'swing'.

comment:5 Changed 4 years ago by anonymous

Forgot to write the link:  http://jsfiddle.net/dgqsw/6/

comment:6 Changed 4 years ago by mail@…

No it's not working, please look here  http://jsfiddle.net/dgqsw/6/

comment:7 Changed 4 years ago by jitter

  • Status changed from closed to reopened
  • Resolution worksforme deleted

comment:8 Changed 4 years ago by jitter

  • Status changed from reopened to closed
  • Resolution set to duplicate

comment:9 Changed 4 years ago by jitter

Duplicate of #7193.

Note: See TracTickets for help on using tickets.