Bug Tracker

Modify

Ticket #7455 (closed bug: invalid)

Opened 3 years ago

Last modified 3 years ago

1.4.4rc2 fails in IE9 Preview 6 under certain conditions

Reported by: Kardax Owned by:
Priority: undecided Milestone: 1.5
Component: unfiled Version: 1.4.4rc
Keywords: Cc:
Blocking: Blocked by:

Description

For reasons not known to me, I'm getting this error:

SCRIPT5022: Exception thrown and not caught jquery-1.4.4rc2.js, line 1016 character 3

On this test page:  http://www.kardax.com/jqueryrctest

Wrapping the line in a try/catch allows jQuery to load properly, otherwise it fails completely in IE 9 platform preview 6. Copying the page to other servers doesn't seem to reproduce the problem... it might have something to do with IE9's processing mode with the various server headers this website is sending.

Other browsers, including IE9 beta (which appears to be synced with platform preview 5) do not have this issue.

Change History

comment:1 Changed 3 years ago by snover

  • Status changed from new to closed
  • Resolution set to invalid

Thanks for the report, but this is not a jQuery bug. Please report it to Microsoft.

comment:2 Changed 3 years ago by Kardax

Reported here:  https://connect.microsoft.com/IE/feedback/details/619551/

There's no guarantee that it'll be fixed, since it seems to be a very rare problem, though I think its chances would go up if more people clicked on the "I can reproduce this bug" button.

Fortunately, since jQuery can be easily modified to work around it, I'll do so as long as it's necessary.

Please follow the  bug reporting guidlines and use  jsFiddle when providing test cases and demonstrations instead of pasting the code in the ticket.

View

Add a comment

Modify Ticket

Action
as closed
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.