Bug Tracker

Modify

Ticket #7382 (closed bug: fixed)

Opened 3 years ago

Last modified 3 years ago

CSS selector [class!=invalid] not working

Reported by: Jeremy S Owned by:
Priority: high Milestone: 1.4.4
Component: selector Version: 1.4.3
Keywords: Cc:
Blocking: Blocked by:

Description

Upon upgrading to jquery 1.4.3 I've noticed I can no longer use "!=" and instead I need to use :not([])

See test case here:  http://jsfiddle.net/n8k7t/

Change History

comment:1 Changed 3 years ago by jitter

Duplicate of #7243. This was only an issue in Firefox and jQuery 1.4.3. It's fixed and will be in jQuery 1.4.4

Version 0, edited 3 years ago by jitter (next)

comment:2 Changed 3 years ago by rwaldron

  • Priority changed from undecided to high
  • Resolution set to fixed
  • Status changed from new to closed
  • Component changed from unfiled to selector
  • Milestone changed from 1.5 to 1.4.4

Further reduced for readability:  http://jsfiddle.net/rwaldron/ThcbG/2/

comment:3 Changed 3 years ago by jitter

Shouldn't this be closed as duplicate instead of fixed?

Please follow the  bug reporting guidlines and use  jsFiddle when providing test cases and demonstrations instead of pasting the code in the ticket.

View

Add a comment

Modify Ticket

Action
as closed
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.