Bug Tracker

Ticket #7377 (closed enhancement: invalid)

Opened 4 years ago

Last modified 2 years ago

(Internet Explorer 9) IE9 returns cached GET response on POST

Reported by: cyberheroo@… Owned by:
Priority: undecided Milestone: 1.5
Component: unfiled Version: 1.4.3
Keywords: Cc:
Blocking: Blocked by:

Description

The latest IE9 Beta returns the response of GET request when you submit a POST to the same URL. Cause of this it is required to allow cache: false also on POST requests I think. (I hope they fix it in the browser but if not you already know it.)

I'm afraid IE9 will be the same desaster as IE6. :/

Change History

comment:1 Changed 4 years ago by jitter

Did you consider reporting this bug to Microsoft?  https://connect.microsoft.com/IE (check the Getting started section)

comment:2 Changed 4 years ago by cyberheroo@…

Yeah, but it requires registration and I am not interessted in IE so much. :->

comment:3 Changed 4 years ago by snover

  • Status changed from new to closed
  • Resolution set to invalid

This is a bug in a beta product. We aren’t going to do anything to work around this issue unless it is present in IE9 final. Please report it upstream.

comment:4 Changed 4 years ago by snover

Since rwaldron asked, specifically this is a violation of RFC 2616 §13.10, which states:

Some HTTP methods MUST cause a cache to invalidate an entity. This is either the entity referred to by the Request-URI, or by the Location or Content-Location headers (if present). These methods are:

  • PUT
  • DELETE
  • POST
Version 0, edited 4 years ago by snover (next)

comment:5 Changed 3 years ago by EricLaw [MSFT]

This problem only occurs when there is no data submitted via the POST.

It is not a regression from previous IE versions; the problem manifests more commonly in IE9 because IE9 follows RFC2616 cache heuristic rules. You'll see the same behavior in IE8 if the response to the GET returns an explicit cache lifetime.

Note: See TracTickets for help on using tickets.