Bug Tracker

Ticket #7367 (closed bug: fixed)

Opened 4 years ago

Last modified 3 years ago

jquery 1.4.3 multiple-selector on IE7 slow to a halt.

Reported by: godric Owned by:
Priority: high Milestone: 1.next
Component: selector Version: 1.4.4rc
Keywords: Cc:
Blocking: Blocked by:

Description

 http://jsfiddle.net/godric/ZjTzy/

Simple, using multiple-selector to fetch 400 elements on IE7, but fine on firefox, chrome, safari.

jquery-1.4.2 = medium slow, but it will finish.
jquery-1.4.3 = won't finish, need to stop script manually.

Suspected to be related to the new browser-native-optimizations.
1.4.3 performs far worse than 1.4.2 on IE7, abnormally & unbearably worse,
maybe some unsuitable optimization got turned on by mistake on IE7?

Change History

comment:1 Changed 4 years ago by rwaldron

  • Priority changed from undecided to high
  • Status changed from new to open
  • Version changed from 1.4.3 to 1.4.4rc
  • Component changed from unfiled to selector
  • Milestone changed from 1.5 to 1.4.5

Confirmed; ~45 seconds to complete in IE7 w/ 1.4.3 and 1.4.4rc1

Version 0, edited 4 years ago by rwaldron (next)

comment:2 follow-up: ↓ 3 Changed 4 years ago by godric

Some more cross-referencing:

I guess it's the same bug as #7341, the multiple-selector might be using .add() internally.

comment:3 in reply to: ↑ 2 Changed 3 years ago by asherh

Replying to godric: We are also stuck with 1.4.2 because of this checkSibling() IE problem. We have a page with 1.4.3+, UI 1.8.11, and a dialog with a large multiple select (hundreds of options). If you click on an option, IE 7/8 freezes in endless JS calls to checkSibling(). Please re-open 7341, many users will be stuck with 1.4.2 until it is fixed. See also:  http://forum.jquery.com/topic/is-this-a-regression-or-a-known-issue-in-1-4-3-and-ie7-8  http://bugs.jqueryui.com/ticket/6644  http://core.trac.wordpress.org/ticket/16643

comment:5 Changed 3 years ago by ktecho@…

I think this bug can be closed too. I had lots of problems while selecting lots of elements with jQuery > 1.4.2, but using 1.6.1 (and 1.6.2) solves the issue.

In fact, I think it's faster now...

comment:6 Changed 3 years ago by ajpiano

  • Status changed from open to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.