Bug Tracker

Ticket #7338 (closed enhancement: duplicate)

Opened 4 years ago

Last modified 4 years ago

remove() with lots of elements inside has gotten significantly slower across all browsers in 1.4.3- very bad in IE 8

Reported by: brad@… Owned by:
Priority: low Milestone:
Component: manipulation Version: 1.4.3
Keywords: Cc:
Blocking: Blocked by:

Description

Starting with jQuery 1.4.3 I have noticed that .remove() on IE8 has become very slow. Its also slower than 1.4.2 on other browsers but isn't as noticeable.

I have created a test in jsfiddle that adds 10,000 divs and then removes the parent using 1.4.2 and 1.4.3.

On a Quad Core PC (8GB Ram) with IE8 I see if taking 111ms using 1.4.2 and 200ms using 1.4.3.

 http://jsfiddle.net/x9tcZ/36/

Change History

comment:1 Changed 4 years ago by SlexAxton

  • Priority changed from undecided to low
  • Status changed from new to open
  • Component changed from unfiled to manipulation
  • Type changed from bug to enhancement

comment:2 Changed 4 years ago by brad@…

So I'm a little confused how this is a feature when it regressed from 1.4.2 to 1.4.3. Its very noticeable in our app and we have had to rollback to 1.4.2 due to user complaints

comment:3 Changed 4 years ago by brad@…

Any chance of consideration for 1.4.4? This is impacting performance in our application.

comment:4 Changed 4 years ago by twatson@…

This also effects our site to the point of causing the "scripts on this page are taking too long warning". What is the status? This has caused a lot of errors and errors in 1.4.2 cant be addressed (the error about unload = undefined) which is fixed in the newer versions.

comment:5 Changed 4 years ago by twatson@…

THis is the code that takes a long time:

$("#SubReportNodeToReplace").empty().html(pHTML);

where pHTML can be a very large fragment. Is there a more effecient way to inser the fragment (and execute any scripts in the fragment)?

comment:6 Changed 4 years ago by rlecour

This is probably related to the same IE8 performance problems reported in #7341 (and other "duplicate" bugs) that were unfortunately dismissed as "won't fix". The comments left by dozens of visitors ALL indicate that they have been forced to downgrade to 1.4.2 because of these performance issues.

Therefore, is this really LOW priority? I think not!

comment:7 Changed 4 years ago by john

  • Status changed from open to closed
  • Resolution set to duplicate

comment:8 Changed 4 years ago by john

Duplicate of #6782.

Note: See TracTickets for help on using tickets.