Bug Tracker

Modify

Ticket #7336 (closed bug: fixed)

Opened 3 years ago

Last modified 3 years ago

CSS width and height of hidden elements is different in opera from all other browsers

Reported by: jitter Owned by:
Priority: low Milestone: 1.4.4
Component: offset Version: 1.4.2
Keywords: width opera Cc: miketaylr
Blocking: Blocked by:

Description

I made a  test case on jsfiddle and all Opera versions and jQuery versions seem to be affected by this (excluding 1.4.3 because of the regressions).

Opera returns a different result from all other browsers (although I think returning 0px is correct when the display: none is set. No?).

For elements which have a height set via css and are hidden because of a display: none on the parent element we get FF: 10px, Opera: 0px

For elements which have no css styling and are hidden because of a display: none on the parent element we get FF: '' (previous versions auto), Opera: 0px (previous versions also 0px)

Change History

comment:1 Changed 3 years ago by SlexAxton

  • Cc miketaylr added
  • Keywords width opera added
  • Status changed from new to open
  • Component changed from unfiled to offset
  • Priority changed from undecided to low

Still valid on 10.70 internal build (the latest I could find) - cc-ing our local opera expert.

Thanks for the nice report jit :)

comment:2 Changed 3 years ago by jitter

This can be closed and milestone 1.4.4 because of commit  fb44450

comment:3 Changed 3 years ago by jitter

  • Status changed from open to closed
  • Resolution set to fixed
  • Milestone changed from 1.5 to 1.4.4

Please follow the  bug reporting guidlines and use  jsFiddle when providing test cases and demonstrations instead of pasting the code in the ticket.

View

Add a comment

Modify Ticket

Action
as closed
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.