Bug Tracker

Modify

Ticket #7292 (closed bug: duplicate)

Opened 4 years ago

Last modified 4 years ago

In IE bind ignores 'change' events if trigger by fireEvent

Reported by: misko@… Owned by:
Priority: undecided Milestone: 1.5
Component: unfiled Version: 1.4.3
Keywords: Cc:
Blocking: Blocked by:

Description

To see the bug use IE8 and visit:  http://www.jsfiddle.net/mhevery/hWsTh/

DESCRIPTION:

When I use bind to register an event on a node, I expect to be able to fire the event through native fireEvent method on IE. (It only works if the user interacts with the widget.) However, if I register the event natively through attachEvent I do get a callback, so I do not think it is an issue with IE, rather it seems to be jQuery 1.4.x issue as the same code works fine in previous versions of jQuery. see it work in 1.3.2:  http://www.jsfiddle.net/mhevery/hWsTh/4/

Change History

comment:1 Changed 4 years ago by snover

  • Status changed from new to closed
  • Resolution set to duplicate

comment:2 Changed 4 years ago by snover

Duplicate of #6420.

Please follow the  bug reporting guidlines and use  jsFiddle when providing test cases and demonstrations instead of pasting the code in the ticket.

View

Add a comment

Modify Ticket

Action
as closed
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.