Bug Tracker

Ticket #7229 (closed bug: fixed)

Opened 4 years ago

Last modified 4 years ago

1.4.3 regression - passing null to event handler

Reported by: matt.parlane@… Owned by: rwaldron
Priority: high Milestone: 1.4.4
Component: event Version: 1.4.3
Keywords: Cc: jdalton
Blocking: Blocked by:

Description

in 1.4.2, this works:

$('body').click(null);

but in 1.4.3, it gives a "handler is null" in the jQuery.event.add function.

It can be worked around in code of course, but I figured you'd want a point release to be backwards-compatible.

Change History

comment:1 Changed 4 years ago by snover

  • Keywords needsreview added

comment:2 Changed 4 years ago by rwaldron

  • Priority changed from undecided to high
  • Status changed from new to open
  • Component changed from unfiled to event

comment:3 Changed 4 years ago by rwaldron

  • Owner set to rwaldron
  • Status changed from open to assigned

comment:7 Changed 4 years ago by rwaldron

  • Cc jdalton added

Disregard previous pull requests.

 http://github.com/jquery/jquery/pull/71

Reflects outcome of suggested handler evaluation by jdalton

comment:8 Changed 4 years ago by rwaldron

#6801 is a duplicate of this ticket.

comment:9 Changed 4 years ago by john

  • Status changed from assigned to closed
  • Resolution set to fixed
  • Milestone changed from 1.next to 1.4.4

comment:10 Changed 4 years ago by matt.parlane@…

Thanks all, very cool.

comment:11 Changed 4 years ago by dmethvin

  • Keywords needsreview removed
Note: See TracTickets for help on using tickets.