Bug Tracker

Ticket #7135 (closed bug: duplicate)

Opened 4 years ago

Last modified 4 years ago

Data Link Focus

Reported by: aburleson Owned by: aburleson
Priority: low Milestone: 1.4.3
Component: datalink Version: 1.4.2
Keywords: Cc:
Blocking: Blocked by:

Description

If an input is focused on page load and that input is linked to a javascript object, changing the text of that input will not change the property of that object. If you focus on another control and put focus back on the textbox and change the text the property will be updated.

Change History

comment:1 Changed 4 years ago by addyosmani

  • need changed from Review to Test Case
  • Owner set to aburleson
  • Status changed from new to pending
  • Component changed from unfiled to datalink
  • Priority changed from undecided to low

Can you provide us with a test case reproducing the above issue so we can test it further?

comment:2 Changed 4 years ago by aburleson

  • Status changed from pending to new

comment:2 Changed 4 years ago by aburleson

Test case is located at  http://jsfiddle.net/NSsys/4/

Please note, this only applies to IE, current system setup.

Windows 7 Ultimate 64-bit (Update-to-date) IE 8

When you click run the focus is set to first name, enter a first name and tab to the next field and the object is not changed. Go back to the first name field and change the value and the property will change.

comment:3 Changed 4 years ago by snover

  • Status changed from new to pending

This ticket has been marked as missing a test case. In an effort to reduce the number of outstanding tickets in the bug tracker, it will be closed automatically in 30 days. In order to prevent this from happening, please provide a working test case. If a test case has already been provided and our records are wrong, please respond to the ticket so that it can be fixed. Thank you!

comment:4 Changed 4 years ago by aburleson

  • Status changed from pending to new

Test case has been submitted, please see previous comment.

comment:5 Changed 4 years ago by snover

  • Status changed from new to closed
  • Resolution set to duplicate

comment:6 Changed 4 years ago by snover

Duplicate of #6374.

Note: See TracTickets for help on using tickets.