Bug Tracker

Ticket #7129 (closed bug: worksforme)

Opened 4 years ago

Last modified 4 years ago

Submit Event "Live" Binding Does Not Work in IE

Reported by: Lucanos Owned by:
Priority: low Milestone:
Component: event Version: 1.4.2
Keywords: form bind live submit ie8 Cc:
Blocking: Blocked by:

Description

Similar issue to Previous Ticket  http://dev.jquery.com/ticket/5705.

When tested in IE8 (unable to confirm IE6 or 7), binding a function to the 'submit' event of a form works in FF3.6, but does not work in IE8.

$('#theForm').live('submit',function(){ return false; });

However, binding the function using the standard jQuery submit event works in IE8.

$('#theForm').submit(function(){ return false; });

Change History

comment:1 Changed 4 years ago by addyosmani

  • Priority changed from undecided to low
  • Status changed from new to closed
  • Resolution set to worksforme

Recreating your original test case here:  http://www.jsfiddle.net/addyosmani/hVQYU/, I've tested the live form submission with IE6, IE7, IE8 and IE9 and all of these were able to correctly bind the event to the form submission without any issues.

Could you please re-submit your ticket with additional information (or a live jsFiddle test that we can investigate further)?.

Thanks.

comment:2 Changed 4 years ago by Lucanos

Just attempted to retest in jsFiddle and was unable to do so. I apologise for taking up your time (I am sure it was failing for me earlier, but, I cannot be positive of the cause).

Thanks for your time.

Note: See TracTickets for help on using tickets.