Bug Tracker

Modify

Ticket #7101 (closed bug: fixed)

Opened 4 years ago

Last modified 4 years ago

IE opacity setting

Reported by: thomaspreu Owned by: snover
Priority: high Milestone: 1.4.3
Component: css Version: 1.4.2
Keywords: opacity filter ie Cc:
Blocking: Blocked by:

Description

When setting a opacity to a element in IE (e.g. through fadeTo()) all previously applied ms filters are lost.

Suggested solution jquery-1.4.2.js line 4602 (jQuery.style) style.filter = ralpha.test(filter) ? filter.replace(ralpha, opacity) : opacity; replace with: style.filter = ralpha.test(filter) ? filter.replace(ralpha, opacity) : filter+' '+opacity;

This solution is not perfect because if a filter is modified by a script (e.g. obj.filters.item("DXImageTransform.Microsoft.Matrix").M11 = costheta;) those modification will be lost. However everything one can do thorough obj.filters is doable with search & replace & append to obj.style.filter as well.

I don't think there is a good solution which would preserve modifications done through obj.filters, the only way it would work is by querying obj.filters for all current values, building a style.filter string with all those found values in it and than apply to obj.style.filter but this is way to complicated to add to jQuery, I would guess 100 lines or more (prove me wrong!).

Change History

comment:1 Changed 4 years ago by snover

  • Owner set to snover
  • Status changed from new to assigned

Duplicate of #4707.

comment:2 Changed 4 years ago by snover

  • need changed from Review to Commit

comment:3 Changed 4 years ago by john

  • Status changed from assigned to closed
  • Resolution set to fixed

Please follow the  bug reporting guidlines and use  jsFiddle when providing test cases and demonstrations instead of pasting the code in the ticket.

View

Add a comment

Modify Ticket

Action
as closed
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.