Bug Tracker

Modify

Ticket #6895 (closed bug: duplicate)

Opened 4 years ago

Last modified 4 years ago

FadeIn of TDs in IE8 does not work as expected

Reported by: Funka Owned by:
Priority: undecided Milestone: 1.4.3
Component: effects Version: 1.4.2
Keywords: ie8 td fadeIn Cc:
Blocking: Blocked by:

Description

Quick Summary: In Internet Explorer 8, fadeIn of all TDs within a TR only actually fades in the first cell of the row. The others remain hidden.

The repro code below works as expected in Firefox, Chrome, and IE7. It does not work in IE8.

Background: Basically, coming from an earlier version of jquery where fading a TR in and out wouldn't always work as expected, I've been fading the contained TDs instead. Now, I'm noticing IE8 does something weird and only fades/shows the first cell in the row. The others are mysteriously not shown.

Please note, this is different than the other types of issues I've found regarding jquery effects on table rows/cells in IE8. In this particular case, all cells after the first column are simply not shown. The speed or "transition" of the fade is not my concern.

Here is how to reproduce:

<form method="post">
	<select id="selector">
		<option>Hidden</option>
		<option>Shown</option>
	</select>
	<table border="1">
		<tbody>
			<tr>
				<td>TD 1A</td>
				<td>TD 1B</td>
			</tr>
			<tr id="targetrow">
				<td style="display:none;">TD 2A</td>
				<td style="display:none;">TD 2B</td>
			</tr>
		</tbody>
	</table>
</form>
<script type="text/javascript">
$(function() {
	$('#selector').change(function() {
		var val = $(this).val();
		var $target = $('#targetrow td');
		if (val == 'Shown') {
			$target.fadeIn('fast');
		}
		else {
			$target.fadeOut('slow');
		}
	});
});
</script> 

Change History

comment:1 Changed 4 years ago by snover

  • Priority set to undecided
  • Status changed from new to closed
  • Resolution set to duplicate

Duplicate of #4512.

comment:2 Changed 4 years ago by addyosmani

#5451 is a duplicate of this ticket.

Please follow the  bug reporting guidlines and use  jsFiddle when providing test cases and demonstrations instead of pasting the code in the ticket.

View

Add a comment

Modify Ticket

Action
as closed
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.