Bug Tracker

Ticket #6852 (closed bug: invalid)

Opened 4 years ago

Last modified 4 years ago

Floating divs are conflicting with hide(), Show()

Reported by: anil_parmar Owned by:
Priority: Milestone: 1.4.3
Component: unfiled Version: 1.4.2
Keywords: floating div Cc: anil_parmar@…
Blocking: Blocked by:

Description

Hi,

I have two requirements on same div in my application. On button click i am doing hide()/Show() of div element. Actually i am doing it on pageload from the server side. So i am using 'block'/'none' property of the style element. Bellow is the code snippet i am using.

divPlantContinous.Attributes.Add("style", "display:block"); divPlantContinous.Attributes.Add("style", "display:none");

On the same time i have requirement that i want the same div floating on my page at particular location. To make it float i have used the bellow code.

$(document).ready(main);

function main() {

$("#divPlantContinous").makeFloat({ x: "10", y: "50", speed: "fast" });

}

Now my the issue is when my div is visible (style=block) it works fine and floats at mentioned position. but on the other side when i give instruction from server side that div should not be visible (style=none), then it is loosing it position and starts floating at x=0 & y=0.

I tried all permutation & combination, but nothing is working so far. please let me is there any other way to do this??? or is it a limitation of JQUERY???

Change History

comment:1 Changed 4 years ago by dmethvin

Please reopen with a simple test case. It should be possible to create a test case that does need any server component at all.

comment:2 Changed 4 years ago by dmethvin

  • Status changed from new to closed
  • Resolution set to invalid
Note: See TracTickets for help on using tickets.