Bug Tracker

Modify

Ticket #6802 (closed bug: duplicate)

Opened 4 years ago

Last modified 4 years ago

IE Memory leak with ajax

Reported by: pascal Owned by:
Priority: undecided Milestone: 1.4.3
Component: ajax Version: 1.4.2
Keywords: Cc:
Blocking: Blocked by:

Description

When I test the code below, i have a memory leak with IE8 (350 KB / 10 min). The file heure.php is a simple 'echo date("d/m/Y - H:i:s");'

<!DOCTYPE html PUBLIC "-W3CDTD XHTML 1.0 TransitionalEN" " http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd"> <html xmlns=" http://www.w3.org/1999/xhtml" xml:lang="fr" >

<head>

<meta http-equiv="Content-Type" content="text/html; charset=UTF-8" /> <script type="text/javascript" src="js/jquery-1.4.2.js"></script>

<script type="text/javascript">

function Heure(){

$.post(

'heure.php', {action: "test"}, function(data) {

document.getElementById("test").innerHTML = data;

}, "text"

);

} setInterval(Heure, 1000);

</script>

</head>

<body>

<div id="test" ></div>

</body>

</html>

Change History

comment:1 in reply to: ↑ description Changed 4 years ago by pascal

It is possible to reduce the leak :

  • not using anonymous function in the $.post(). (thanks to the irc channel of prototype ;-) )

But there is still a memory leak.

comment:3 Changed 4 years ago by cobexer

duplicate of  http://dev.jquery.com/ticket/6242 ? the proposed change in #6242 fixed the memory leak for me

comment:4 Changed 4 years ago by dmethvin

  • Priority set to undecided
  • Status changed from new to closed
  • Resolution set to duplicate

Dup of #6242.

Please follow the  bug reporting guidlines and use  jsFiddle when providing test cases and demonstrations instead of pasting the code in the ticket.

View

Add a comment

Modify Ticket

Action
as closed
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.