Bug Tracker

Ticket #6785 (closed bug: duplicate)

Opened 4 years ago

Last modified 4 years ago

DOM mutation events can have text nodes as target

Reported by: hesselink Owned by: hesselink
Priority: undecided Milestone: 1.4.3
Component: event Version: 1.4.2
Keywords: Cc:
Blocking: Blocked by:

Description

I've added a small fix to the jquery event code: if the event target was a text node, it would be set to the parent of that text node. However, for DOM mutation events, text nodes are perfectly valid (and useful) targets. So I've added an extra check to see if the event type starts with 'DOM', and not fix the target in that case.

See  http://github.com/typLAB/jquery/commit/6284b37914e3f4d6634e37cbf93d76d1dc6ee3bd

Change History

comment:1 Changed 4 years ago by rwaldron

  • Owner set to hesselink
  • Priority set to undecided
  • Status changed from new to pending

Please provide a distilled and reduced jsFiddle test case, thanks!

comment:2 Changed 4 years ago by hesselink

  • Status changed from pending to new

This is a duplicate of #5539.

comment:3 Changed 4 years ago by rwaldron

  • Status changed from new to closed
  • Resolution set to duplicate

comment:4 Changed 4 years ago by rwaldron

Duplicate of #5539.

Note: See TracTickets for help on using tickets.