Bug Tracker

Ticket #6708 (closed bug: fixed)

Opened 4 years ago

Last modified 3 years ago

Opera has inconsistent result for usemap attribute value

Reported by: kemayo Owned by: timmywil
Priority: low Milestone: 1.6
Component: attributes Version: 1.5.2
Keywords: Cc:
Blocking: Blocked by:

Description

With the html: <img id="foo" src="foo.gif" usemap="#bar"/>

This happens:

$('#foo').attr('usemap') == "http://abc.com/abc.html#bar";
$('#foo').get(0).getAttribute('usemap') == '#bar';

All other browsers I've tested return just '#bar' as the attr for usemap.

Change History

comment:1 Changed 4 years ago by dmethvin

Looks like this is fixed if useMap is added to the special regexp:

	rspecialurl = /href|src|style|useMap/,

comment:2 Changed 4 years ago by miketaylr

  • Owner set to miketaylr
  • Priority set to low
  • Version changed from 1.4.2 to 1.4.3
  • Status changed from new to assigned
  • Milestone changed from 1.4.3 to 1.4.5

comment:3 Changed 4 years ago by miketaylr

Fiddle showing confirmed behavior:  http://jsfiddle.net/uguTR/

comment:4 Changed 4 years ago by dmethvin

  • Milestone changed from 1.4.5 to 1.5

comment:5 Changed 3 years ago by timmywil

  • Owner changed from miketaylr to timmywil
  • Version changed from 1.4.3 to 1.5.2
  • Milestone set to 1.6

Also fixed in attrhooks for jQuery 1.6:  http://jsfiddle.net/uguTR/2/

comment:6 Changed 3 years ago by timmywil

  • Status changed from assigned to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.