Bug Tracker

Ticket #6493 (closed bug: duplicate)

Opened 4 years ago

Last modified 4 years ago

Attribute Starts With Selector and Attribute Contains Selector does not work with escaped meta-characters in find()

Reported by: rockitbaby Owned by:
Priority: undecided Milestone:
Component: selector Version: 1.4.2
Keywords: find selector Cc:
Blocking: Blocked by:

Description (last modified by snover) (diff)

The Attribute Starts With Selector [name=value] and Attribute Contains Selector [name*=value] does not return any elements when used in the find() function and the value contains escaped meta-characters.

$('a[href^=\\#]').size() != $('body').find('a[href^=\\#]').size();

Test file is attached.

Attachments

attributes-starts-with-find-test.html Download (2.7 KB) - added by rockitbaby 4 years ago.
Test

Change History

Changed 4 years ago by rockitbaby

Test

comment:1 in reply to: ↑ description Changed 4 years ago by nathank

I have found the same problem. I need a fix for this ASAP. Thanks.

comment:2 Changed 4 years ago by snover

  • Milestone 1.4.3 deleted

Resetting milestone to future.

comment:3 Changed 4 years ago by snover

  • Priority set to undecided
  • Status changed from new to closed
  • Resolution set to duplicate
  • Description modified (diff)

comment:4 Changed 4 years ago by snover

Duplicate of #6093.

Note: See TracTickets for help on using tickets.