Bug Tracker

Modify

Ticket #6465 (closed bug: duplicate)

Opened 4 years ago

Last modified 2 years ago

Ajax, firefox 6.3.6 returns statuscode 0 when server is down, leads to succes callback

Reported by: sander Owned by:
Priority: Milestone: 1.4.2
Component: ajax Version: 1.4.2
Keywords: Cc:
Blocking: Blocked by:

Description

When i send an Ajax request with jQuery in a Firefox 3.6.3 browser, and the server is completely down, it returns status code 0. jQuery currently interprets a status=0 as a success, from the comment in the code for opera(which seem to return 0 instead of 304 sometimes). So i think a browser specific check is needed unfortunately.

Change History

comment:1 Changed 4 years ago by curiousdannii

Duplicate of #6060

comment:2 Changed 4 years ago by snover

  • Status changed from new to closed
  • Resolution set to duplicate

Please follow the  bug reporting guidlines and use  jsFiddle when providing test cases and demonstrations instead of pasting the code in the ticket.

View

Add a comment

Modify Ticket

Action
as closed
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.