Bug Tracker

Modify

Ticket #6367 (closed bug: duplicate)

Opened 4 years ago

Last modified 4 years ago

Exeption throw

Reported by: Aristos Owned by:
Priority: Milestone: 1.4.3
Component: event Version: 1.4.2
Keywords: Cc:
Blocking: Blocked by:

Description

ver 1.4.2 Line 1919, inside handle: function( event ).

on this point, some time (when I make refress on ie, just before leaving the page for the refress) the events are undefined, so the handlers = events[] throw an error.

var events = jQuery.data(this, "events"), handlers = events[ event.type ];

Try this way.

var events = jQuery.data(this, "events");

if ( events ) {

var handlers = events[ event.type ];

if(handlers) {

Clone the handlers to prevent manipulation handlers = handlers.slice(0);

Attachments

jQueryBug1.gif Download (16.4 KB) - added by Aristos 4 years ago.
Capture for this bug.

Change History

comment:1 Changed 4 years ago by dmethvin

  • Status changed from new to closed
  • Resolution set to invalid

Please reopen with a test case that includes html and javascript needed to reproduce the problem.

comment:2 Changed 4 years ago by Aristos

  • Status changed from closed to reopened
  • Resolution invalid deleted

I can not give you test case at least now, because this happens on a very difficult page on my backoffice on my developed computer on private program. And happens when I try to insert and develop a chart gallery the Highcharts. What I can give you is a screen capture if you like.

This page that this bug happens, is on asp.net including some Yahoo compoments, jQuery, prototype, and Ms Ajax. Sounds complicate but it is not and working fine, until I catch up this exception.

Anyway Can you see that with out test, the bug exist ?

If the jQuery.data(this, "events");, return undefined - null, the bug exist, because the next event the events[] just throw an exception.

Anyway thank you in advanced.

Changed 4 years ago by Aristos

Capture for this bug.

comment:3 Changed 4 years ago by john

  • Status changed from reopened to closed
  • Resolution set to duplicate
  • Component changed from unfiled to event

Ah, ok - yeah, that bug has already been fixed and will be in jQuery 1.4.3.

Please follow the  bug reporting guidlines and use  jsFiddle when providing test cases and demonstrations instead of pasting the code in the ticket.

View

Add a comment

Modify Ticket

Action
as closed
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.