Bug Tracker

Modify

Ticket #6343 (closed bug: duplicate)

Opened 4 years ago

Last modified 2 years ago

XMLHttpRequest Leak in IE 7

Reported by: Daazku Owned by:
Priority: undecided Milestone: 1.4.3
Component: ajax Version: 1.4.2
Keywords: Cc:
Blocking: Blocked by:

Description

The default behavior of jQuery is to create an XMLHttpRequest if the browser support it. But in IE 7 (don't know for other versions) XMLHttpRequest don't release resources until you refresh the page or navigate away.

We should handle that and supply ActiveXObject by default for IE.

Attachments

TestActualjQueryImplementation.html Download (603 bytes) - added by Daazku 4 years ago.
Test that show the leak (Check task manager)
TestPossibleFixjQueryImplementation.html Download (1012 bytes) - added by Daazku 4 years ago.
Test that fix the leak (Check task manager)

Change History

Changed 4 years ago by Daazku

Test that show the leak (Check task manager)

Changed 4 years ago by Daazku

Test that fix the leak (Check task manager)

comment:1 Changed 4 years ago by dmethvin

  • Priority set to undecided
  • Status changed from new to closed
  • Resolution set to duplicate

Duplicate of #6242 .

Please follow the  bug reporting guidlines and use  jsFiddle when providing test cases and demonstrations instead of pasting the code in the ticket.

View

Add a comment

Modify Ticket

Action
as closed
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.