Bug Tracker

Modify

Ticket #6266 (closed bug: duplicate)

Opened 4 years ago

Last modified 4 years ago

Unbinding custom events results in TypeError

Reported by: gillis Owned by:
Priority: Milestone: 1.4.3
Component: event Version: 1.4.2
Keywords: Cc:
Blocking: Blocked by:

Description

test case

var fn = new function(){}; jQuery(fn).bind('customEvent',function(){}); jQuery(fn).unbind();

result

type: TypeError lineNumber : 2074 message: elem.removeEventListener is not a function

Change History

comment:1 Changed 4 years ago by john

  • Status changed from new to closed
  • Resolution set to duplicate
  • Component changed from unfiled to event

Duplicate of #6184.

Please follow the  bug reporting guidlines and use  jsFiddle when providing test cases and demonstrations instead of pasting the code in the ticket.

View

Add a comment

Modify Ticket

Action
as closed
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.