Bug Tracker

Ticket #6173 (closed bug: duplicate)

Opened 5 years ago

Last modified 3 years ago

$.ajax() doesn't fire error-callback when manually aborted

Reported by: dpree Owned by:
Priority: undecided Milestone: 1.4.2
Component: ajax Version:
Keywords: ajax error xhr callback http status Cc:
Blocking: Blocked by:

Description

example:

start a xhr like:

var myxhr = $.ajax({ [...]

success: function(data, textStatus, xhr){ console.log('success'); console.log('xhr.status: '+xhr.status); },

error: function() { console.log('error');

} });

hit ESC or cancel via calling myxhr.abort()

console-output => "success" and "xhr.status: 0"

i would expect instead (and so it was in jquery1.3.2) => "error"

tested with jquery-1.4.2 using ff3.0.18 and ff3.5.8

Change History

comment:1 Changed 4 years ago by snover

  • Priority set to undecided
  • Status changed from new to closed
  • Resolution set to duplicate

Duplicate of #6060.

Note: See TracTickets for help on using tickets.