Bug Tracker

Modify

Ticket #6108 (closed bug: wontfix)

Opened 4 years ago

Last modified 3 years ago

.live(event) does not contain event.data in 1.4.2

Reported by: skyzyx Owned by:
Priority: Milestone: 1.4.2
Component: event Version:
Keywords: Cc:
Blocking: Blocked by:

Description

$(selector).live('click', function(event) {

event.data is undefined

});

Full test case with 1.4.1 and 1.4.2 is at  http://ryanparman.com/labs/jquery_event_regression/

Change History

comment:1 follow-up: ↓ 2 Changed 4 years ago by john

  • Status changed from new to closed
  • Resolution set to wontfix

This is correct - the original .data there was never meant to be exposed (we were forced to pass it in because of how the jQuery event system was structured). Note that it doesn't make sense to have data coming in for something that doesn't actually have data on it.

comment:2 in reply to: ↑ 1 Changed 3 years ago by yanibie

how about when you .live register to events like drop that require data ?

Replying to john:

This is correct - the original .data there was never meant to be exposed (we were forced to pass it in because of how the jQuery event system was structured). Note that it doesn't make sense to have data coming in for something that doesn't actually have data on it.

Please follow the  bug reporting guidlines and use  jsFiddle when providing test cases and demonstrations instead of pasting the code in the ticket.

View

Add a comment

Modify Ticket

Action
as closed
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.