Bug Tracker

Modify

Ticket #6090 (closed bug: worksforme)

Opened 4 years ago

Last modified 3 years ago

When element has anything within it with -webkit-column-count, slideDown() extends too long and then flickers back

Reported by: aaronshaf Owned by: aaronshaf
Priority: low Milestone: 1.4.2
Component: effects Version: 1.4.1
Keywords: -webkit-column-count slideDown() Cc:
Blocking: Blocked by:

Description

You can see the error at carm.org when you click on "Dictionary of theology" on the left column. This is a problem in Safari and Webkit, not Firefox.

Change History

comment:1 Changed 4 years ago by addyosmani

  • Owner set to aaronshaf
  • Priority set to undecided
  • Status changed from new to pending

Could you possibly submit a valid test case that we could take a look at?

Last edited 3 years ago by addyosmani (previous) (diff)

comment:2 Changed 3 years ago by aboushley

There is definitely some choppiness in the carm.org menu, but for me it seems to be that it doesn't extend far enough and then jumps down to its ending position... but that's a different issue entirely. I used some of the basic structure you referenced, and then convereted it to use -webkit-column-count as you perscribed and things seem to work just fine for me in Chrome using jQuery 1.2.6 or 1.4.2.  http://jsfiddle.net/Ym765/1/

comment:3 Changed 3 years ago by addyosmani

  • Keywords -webkit-column-count slideDown() added
  • Priority changed from undecided to low
  • Status changed from pending to closed
  • Resolution set to worksforme

Based on the test-case submitted by aboushley, I can confirm that this is working fine using jQuery core 1.2.6, 1.4.2, 1.4.3 and 1.4.4.

Please follow the  bug reporting guidlines and use  jsFiddle when providing test cases and demonstrations instead of pasting the code in the ticket.

View

Add a comment

Modify Ticket

Action
as closed
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.