Bug Tracker

Modify

Ticket #5816 (closed bug: duplicate)

Opened 4 years ago

Last modified 3 years ago

href onclick return doesn't work in IE7/8 with a $(function(){ live click }

Reported by: geki007 Owned by: brandon
Priority: major Milestone: 1.4.1
Component: event Version: 1.4
Keywords: live click href Cc:
Blocking: Blocked by:

Description

if you click on link it shouldn't do something but it goes to "/test" (see the attached file) in FF and chrome it works

i think the problem is in jquery.js on line 1557 (function) or 1861 (in this line on 1.3 there is no return, or the function has a bug)

on 1.3 it works

Attachments

test.html Download (502 bytes) - added by geki007 4 years ago.
Testcase

Change History

Changed 4 years ago by geki007

Testcase

comment:1 Changed 4 years ago by iraebrasil

This is an exact duplicate of:http://dev.jquery.com/ticket/5835

My commit fixes both:  http://github.com/irae/jquery/commit/6438ab0da979307d8ea0ec5183d6a5e5a57bead8

comment:2 Changed 3 years ago by addyosmani

  • Status changed from new to closed
  • Resolution set to duplicate

comment:3 Changed 3 years ago by addyosmani

Duplicate of #5835.

Please follow the  bug reporting guidlines and use  jsFiddle when providing test cases and demonstrations instead of pasting the code in the ticket.

View

Add a comment

Modify Ticket

Action
as closed
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.