Bug Tracker

Ticket #5756 (closed bug: duplicate)

Opened 5 years ago

Last modified 5 years ago

jQuery 1.3.2 document.ready() event does not fire with persistent proxy connections

Reported by: censornet Owned by: brandon
Priority: critical Milestone: 1.4
Component: event Version: 1.3.2
Keywords: ready Cc:
Blocking: Blocked by:

Description

We develop a web proxy server which impliments client side HTTP persistent connections. This seems to cause a bug in jQuery's docuemnt.ready() event handling, resulting in it failing to fire while the persistent connection (socket) to the proxy server from the web browser remains open.

This results in web pages which use the document.ready() event failing to load until the socket times-out and closes.

I have attached a packet capture file (pcap) which can be opened with the free Wireshark network protocol analyser. It shows the browser using a persistent connection to make requests to the proxy server which (as expected) remains open at the end of the transactions. This (I think) is the cause of the problem in jQuery's ready event handling logic.

Change History

comment:1 Changed 5 years ago by dmethvin

  • Status changed from new to closed
  • Resolution set to duplicate

Dup of #5757 which has the attachment.

Note: See TracTickets for help on using tickets.