Bug Tracker

Ticket #5664 (closed bug: wontfix)

Opened 5 years ago

Last modified 3 years ago

querySelectorAll with nth-child in webkit

Reported by: caii Owned by: john
Priority: low Milestone: 1.next
Component: selector Version: 1.4a1
Keywords: querySelectorAll needsreview Cc:
Blocking: Blocked by:

Description

<ul>
		<li>text 01</li>
		<li>text 02</li>
		<li>text 03</li>
		<li>text 04</li>
		<li>text 05</li>
		<li>text 06</li>
		<li>text 07</li>
		<li>text 08</li>
</ul>
<ul>
		<li>text 01</li>
		<li>text 02</li>
		<li>text 03</li>
		<li>text 04</li>
		<li>text 05</li>
		<li>text 06</li>
		<li>text 07</li>
		<li>text 08</li>
</ul>
<script>
document.querySelectorAll("ul li:nth-child(4n+3),ul li:nth-child(4n+2)").length // FF:8   ;webkit:0;
//but jquery use querySelectorAll on that
jQuery("ul li:nth-child(4n+3),ul li:nth-child(4n+2)").length // FF:8   ;webkit:0;
</script>

Change History

comment:1 Changed 4 years ago by dmethvin

  • Priority changed from major to low
  • Status changed from new to open

 http://jsfiddle.net/dmethvin/qW2tt/

Looks like a qSA bug with webkit.

comment:2 Changed 3 years ago by danheberden

  • Keywords needsreview added

comment:3 Changed 3 years ago by danheberden

  • Milestone changed from 1.4 to 1.next

comment:4 Changed 3 years ago by ajpiano

  • Status changed from open to closed
  • Resolution set to wontfix

This is a webkit bug ( https://bugs.webkit.org/show_bug.cgi?id=32856) for which we cannot come up with a tenable, non-invasive solution.

comment:5 Changed 3 years ago by ajpiano

#9882 is a duplicate of this ticket.

Note: See TracTickets for help on using tickets.