Bug Tracker

Ticket #5633 (closed bug: invalid)

Opened 5 years ago

Last modified 4 years ago

jquery function with context doesn't work with attribute selectors

Reported by: bic72 Owned by:
Priority: major Milestone: 1.4
Component: core Version: 1.3.2
Keywords: context parameter attribute selector Cc:
Blocking: Blocked by:

Description

With the following HTML: <div class="my_div"> <form name="my_form"> ... </form> </div>

This will not work: var context = $('.my_div'); $('form[name="my_form"]', context);

This will work: $('form', context);

Change History

comment:1 Changed 5 years ago by bic72

I forgot to mention that this works fine in version 1.2.6

comment:2 Changed 5 years ago by bic72

Please close this ticket. False alarm. I made a mistake when constructing my minimal test case and I'm not able to repro outside of a much more complex app. I suspect it's something to do with Firebug. Sorry.

comment:3 Changed 4 years ago by addyosmani

  • Status changed from new to closed
  • Resolution set to invalid

Closing ticket as original ticket submitter has updated to say that this is not an issue with jQuery but was rather one more likely to do with Firebug. If the issue is re-experienced, please feel free to submit a new ticket and we will investigate accordingly.

Note: See TracTickets for help on using tickets.