Bug Tracker

Modify

Ticket #5598 (closed bug: invalid)

Opened 4 years ago

Last modified 4 years ago

[autocomplete] selectCurrent() -- wordAt is sometimes undefined after each loop

Reported by: docwhat Owned by:
Priority: major Milestone: 1.4
Component: plugin Version: 1.4a1
Keywords: Cc:
Blocking: Blocked by:

Description

How I reproduce it:

autoFill: true, max: 100, selectFirst: false, mustMatch: true, multiple: true, multipleSeparator: ','

  • In a field that has "value1".
  • Enter ", value".
  • Wait for list of values ("value" through "value9")
  • Select "value2"
  • Press enter.
  • field now has "value1,value" in it.

I expected it to have"value1,value2" in it.

This is because wordAt is undefined by the time it comes out of the .each() on line 225.

Patch: diff --git a/js/vivisimo.js b/js/vivisimo.js index dbf68e0..b334544 100644 --- a/js/vivisimo.js +++ b/js/vivisimo.js @@ -5,7 +5,7 @@ if (typeof jQuery.fn.submitOnEnter === 'undefined') {

jQuery(this) .listenForEnter() .bind('pressedEnter', function() {

  • $(this).parent('form').submit();

+ jQuery(this).parent('form').submit();

});

});

};

Change History

comment:1 Changed 4 years ago by john

  • Status changed from new to closed
  • Resolution set to invalid

We don't accept plugin bugs here anymore.

Please follow the  bug reporting guidlines and use  jsFiddle when providing test cases and demonstrations instead of pasting the code in the ticket.

View

Add a comment

Modify Ticket

Action
as closed
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.