Bug Tracker

Modify

Ticket #5568 (closed bug: fixed)

Opened 4 years ago

Last modified 22 months ago

Selectors behave differently with comments tags on FF/IE

Reported by: PERECil Owned by: john
Priority: high Milestone: 1.8
Component: selector Version: 1.4.4
Keywords: Cc:
Blocking: Blocked by:

Description

See test case. Basically, Firefox ignores the comments as a node in the DOM, and IE (all versions tested) seems to count the comments in the DOM.

I don't know if this behavior is intended...

Attachments

test.html Download (799 bytes) - added by PERECil 4 years ago.

Change History

Changed 4 years ago by PERECil

comment:1 Changed 3 years ago by jitter

  • Priority changed from major to high
  • Status changed from new to open
  • Version changed from 1.3.2 to 1.4.4
  • Milestone changed from 1.4 to 1.5

IE returns comment nodes too when getElementsByTagName("*") is used. This is a bug in Sizzle.find

 test case alerts 1 in IE 0 in all other browsers

 test case 2 shows simple case where this becomes a problem for jQuery

comment:2 Changed 3 years ago by danheberden

  • Milestone set to 1.next

comment:3 Changed 3 years ago by dmethvin

Triaged as valid, need to fix the gEBTN in Sizzle.find as mentioned by jitter.

comment:4 Changed 23 months ago by dmethvin

#7276 is a duplicate of this ticket.

comment:5 Changed 22 months ago by timmywil

  • Status changed from open to closed
  • Resolution set to fixed
  • Milestone changed from 1.next to 1.8

Please follow the  bug reporting guidlines and use  jsFiddle when providing test cases and demonstrations instead of pasting the code in the ticket.

View

Add a comment

Modify Ticket

Action
as closed
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.