Bug Tracker

Modify

Ticket #5458 (closed bug: duplicate)

Opened 4 years ago

Last modified 4 years ago

$.fn.trigger fails to apply extra data to callback for live events

Reported by: micah Owned by: brandon
Priority: major Milestone: 1.4
Component: event Version: 1.3.2
Keywords: live, trigger, bind, arguments, data Cc:
Blocking: Blocked by:

Description

To reproduce:

$('body').bind('works', function(e, data) {
    console.log('proper args: ', arguments);
}).trigger('works', ['arg2', 'arg3']);

$('body').live('borked', function(e, data) {
    console.log('wrong args: ', arguments);
}).trigger('borked', ['arg2', 'arg3']);

Note that arg2 and arg3 are not passed to the callback for the live event but work properly on the regularly bound one.

Change History

comment:1 Changed 4 years ago by micah

Whoops, dupe of #4532

comment:2 Changed 4 years ago by addyosmani

  • Status changed from new to closed
  • Resolution set to duplicate

Closing due to duplicate.

Please follow the  bug reporting guidlines and use  jsFiddle when providing test cases and demonstrations instead of pasting the code in the ticket.

View

Add a comment

Modify Ticket

Action
as closed
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.