Bug Tracker

Modify

Ticket #5069 (closed bug: worksforme)

Opened 5 years ago

Last modified 3 years ago

form selector doesn't work

Reported by: guramrit Owned by: guramrit
Priority: low Milestone:
Component: selector Version: 1.3.2
Keywords: form selector Cc:
Blocking: Blocked by:

Description

form selector doesn't work properly in 1.3.2 release, but it works in 1.2.6. I wanted to bind submit event to form using $('#divid form').submit(function(){ }); but no output, works in 1.2.6

I'm able to make it happen using $($('#divid form')[0].form).submit(function() { });

but it's not the good way, i think.

Change History

comment:1 Changed 5 years ago by dmethvin

Please submit a complete test case.

comment:2 Changed 3 years ago by rwaldron

  • Owner changed from john to guramrit
  • Priority changed from critical to undecided
  • Status changed from new to pending
  • Milestone 1.4 deleted

Please provide a distilled and reduced jsFiddle test case, thanks!

comment:3 Changed 3 years ago by aboushley

Created a jsfiddle  http://jsfiddle.net/9KWuQ/ from this fiddle I cannot reproduce the issue based on the given repro case.

comment:4 Changed 3 years ago by addyosmani

  • Keywords form selector added
  • Priority changed from undecided to low
  • Status changed from pending to closed
  • Resolution set to worksforme

Your test case works fine in both jQuery 1.3.2 (see aboushley's test case above) and it also works fine with jQuery 1.4.4. See  Live Test Case. As two members of the triage team have been unable to reproduce this issue based on the information provided I am closing this ticket as it works for us. If you have further test cases you would like to submit we'll be happy to re-investigate.

Please follow the  bug reporting guidlines and use  jsFiddle when providing test cases and demonstrations instead of pasting the code in the ticket.

View

Add a comment

Modify Ticket

Action
as closed
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.