Bug Tracker

Modify

Ticket #5047 (closed bug: duplicate)

Opened 5 years ago

Last modified 4 years ago

jQuery.fx.update incorrectly sets elements' inline style display to "block"

Reported by: enaeseth Owned by:
Priority: major Milestone: 1.4
Component: effects Version: 1.3.2
Keywords: display inline-block table-cell Cc:
Blocking: Blocked by:

Description

During height and width animations, jQuery.fx.update adds an inline style to its targeted elements changing their display to "block".

This behavior is now incorrect. Browsers have implemented support for more of the CSS2 values for display like "inline-block", "table-cell", and "list-item", and – importantly – they have let these new values override rendering behavior for elements that previously got special handling. In the past, when a display of "block" was applied to a <td> element, it was still rendered as a table cell, but this is no longer true. In modern browsers, it is now rendered as an actual block, just as a <div> naturally would be.

To function as expected, jQuery.fx.update must be updated with either a whitelist of display values that should be changed to "block" (e.g., "inline"), or a blacklist of display values that should not be changed (e.g., "inline-block").

Change History

comment:1 Changed 4 years ago by snover

  • Status changed from new to closed
  • Resolution set to duplicate

Duplicate of #2185.

Please follow the  bug reporting guidlines and use  jsFiddle when providing test cases and demonstrations instead of pasting the code in the ticket.

View

Add a comment

Modify Ticket

Action
as closed
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.