Bug Tracker

Ticket #4978 (closed enhancement: fixed)

Opened 5 years ago

Last modified 3 years ago

jQuery.prop missing cellpadding?

Reported by: janzich Owned by:
Priority: low Milestone: 1.6
Component: attributes Version: 1.5.2
Keywords: cellpadding prop Cc:
Blocking: Blocked by:

Description

I'm not entirely familiar with the purpose of jQuery.prop, but I'm guessing its purpose is to fix some attributes to their standard form. It seems that it's missing cellPadding (cellSpacing is already there) which causes a problem in IE7 (tested in IE8 compatibility mode).

The following snippet in IE7 sets cellspacing, but does not set cellpadding:

$("<table/>").attr("cellspacing", "10").attr("cellpadding", "10");

The following works:

$("<table/>").attr("cellspacing", "10").attr("cellPadding", "10");

The problem is caused by the case-sensitivity of the setAttribute function in pre-IE8 (documented in MSDN).

Change History

comment:1 Changed 4 years ago by dmethvin

  • Component changed from support to attributes

comment:2 Changed 4 years ago by SlexAxton

  • Keywords prop added
  • Status changed from new to open
  • Type changed from bug to enhancement
  • Milestone changed from 1.4 to 1.5

Adding this as an enhancement since jQuery doesn't necessarily claim support for this.

comment:3 Changed 4 years ago by SlexAxton

  • Priority changed from major to low

comment:4 Changed 4 years ago by timmywil

  • Version changed from 1.3.2 to 1.5.2

I think we can support this in 1.6. It's a one-line addition. Anyone opposed?

comment:5 Changed 4 years ago by timmywil

comment:6 Changed 4 years ago by john

  • Status changed from open to closed
  • Resolution set to fixed
  • Milestone set to 1.6

Landed.

Note: See TracTickets for help on using tickets.