Bug Tracker

Modify

Ticket #4811 (closed bug: duplicate)

Opened 5 years ago

Last modified 3 years ago

JSONP Ajax does not always call success or error

Reported by: Connorhd Owned by:
Priority: minor Milestone: 1.4
Component: ajax Version: 1.3.2
Keywords: Cc:
Blocking: Blocked by:

Description

JSONP requests do not call success or error on a malformed JSONP response, this seems bad behaviour.

Change History

comment:1 Changed 5 years ago by dmethvin

malsup has this wrapper that fixes the issue:

 http://gist.github.com/82181

comment:2 Changed 3 years ago by snover

  • Status changed from new to closed
  • Resolution set to duplicate

comment:3 Changed 3 years ago by snover

Duplicate of #5201.

Please follow the  bug reporting guidlines and use  jsFiddle when providing test cases and demonstrations instead of pasting the code in the ticket.

View

Add a comment

Modify Ticket

Action
as closed
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.