Bug Tracker

Modify

Ticket #4797 (closed bug: worksforme)

Opened 5 years ago

Last modified 4 years ago

Firefox crash with label click handler setting display: block and hiding container

Reported by: coreyti Owned by:
Priority: low Milestone: 1.4
Component: event Version: 1.3.2
Keywords: firefox crash Cc: corey@…
Blocking: Blocked by:

Description

The following handler reliably crashes OS X Firefox (version 3.0.11, tried on 3 computers):

$(function() {
  $('label').click(function() {
    // order is important...
    $(this).css('display', 'block');
    $('div#container').hide();
  });
});

Attempted to create a unit test on jQuery source, but programmatic clicks do not cause the crash.

See attached html for a crashing example with notes. Also, a patch is included with a potential fix.

Attachments

firefox-crash-fix.patch Download (903 bytes) - added by coreyti 5 years ago.
patch for crash fix
firefox-crash.html Download (897 bytes) - added by coreyti 5 years ago.
example for crash

Change History

Changed 5 years ago by coreyti

patch for crash fix

Changed 5 years ago by coreyti

example for crash

comment:1 Changed 4 years ago by addyosmani

  • need changed from Review to Patch
  • Priority changed from major to low
  • Component changed from fx to event

I can confirm that this issue crashes FireFox 3 using the above submitted code (on both Windows and OSX), also found here:  http://jsfiddle.net/addyosmani/qUhc2/

This bug does not affect FireFox 3.5 and above.

In case it would assist the patcher, current statistics show that between 3-4% of users are currently still using FireFox 3.0 and have yet to upgrade.

comment:2 Changed 4 years ago by snover

  • Status changed from new to closed
  • Resolution set to worksforme

I am not able to reproduce a crash in the latest version of Firefox 3.0 (3.0.19).

Please follow the  bug reporting guidlines and use  jsFiddle when providing test cases and demonstrations instead of pasting the code in the ticket.

View

Add a comment

Modify Ticket

Action
as closed
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.