Bug Tracker

Modify

Ticket #4779 (closed bug: duplicate)

Opened 5 years ago

Last modified 3 years ago

ClearType issue with fadeIn() and fadeOut() in IE only

Reported by: Reado Owned by:
Priority: minor Milestone: 1.4
Component: effects Version: 1.3.2
Keywords: fadein, fadeout, cleartype Cc:
Blocking: Blocked by:

Description

When using either fadeIn() or fadeOut() in IE7 (not sure if this affects other versions) the text doesn't use ClearType when fading in/out.

Use of this.style.remoteAttribute("filter") seems to work in IE but not in Firefox. In IE it applies the filter change after it has faded in/out - which still doesn't look right.

This issue doesn't occur with Firefox.

Code:

$(document).ready(function(){

$("#container").hide().fadeIn(150);

});

Suggested fix is here:  http://jquery-howto.blogspot.com/2009/02/font-cleartype-problems-with-fadein-and.html

I searched for this bug but couldn't find it - so apologise if it already exists.

Change History

comment:1 Changed 3 years ago by dmethvin

The problem with removing the inline filter is that the element will return to the cascade-defined filter if there is one present. I know there is a similar ticket around but I'll leave this open for now.

comment:2 Changed 3 years ago by snover

  • Status changed from new to closed
  • Resolution set to duplicate

comment:3 Changed 3 years ago by snover

Duplicate of #6652.

Please follow the  bug reporting guidlines and use  jsFiddle when providing test cases and demonstrations instead of pasting the code in the ticket.

View

Add a comment

Modify Ticket

Action
as closed
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.