Bug Tracker

Modify

Ticket #4760 (closed bug: invalid)

Opened 5 years ago

Last modified 2 years ago

IE Raises error on page load/close in jquery

Reported by: bearp Owned by:
Priority: minor Milestone: 1.4
Component: unfiled Version: 1.3.2
Keywords: Cc:
Blocking: Blocked by:

Description

IE 6 and 8 raise an error on page load/close in jquery (I could not reproduce this error using IE 7). I did have a script debugger installed, the highlighted code for the error is:

H.pageX=H.clientX+(I&&I.scrollLeft
E&&E.scrollLeft0)-(I.clientLeft0)

within the jquery-1.3.2.min.js file. A little more background: this error occurs when www.google.com is loaded and the jquery code is running in a Conduit HTML component (see  http://www.conduit.com) in my toolbar. This may happen on more webpages, but I know it does happen on google.

IE's dialog says: Error line 19, Object doesn't support this action.

Attachments

famos-explore.txt Download (1.5 KB) - added by bearp 5 years ago.
HTML component code
line2741.txt Download (110 bytes) - added by bearp 5 years ago.
Line 2741

Change History

comment:1 Changed 5 years ago by bearp

Looks like the post stripped out the or symbol. The code is (all on one line): H.pageX=H.clientX+(I&&I.scrollLeft (2 vertical bars, no spaces) E&&E.scrollLeft (2 vertical bars, no spaces) 0)-(I.clientLeft (2 vertical bars, no spaces) 0)

comment:2 Changed 5 years ago by dmethvin

Please attach a simple test case that demonstrates the problem. Use the uncompressed version of jQuery to simplify debugging.

comment:3 Changed 5 years ago by bearp

Unfortunately, this bug can't be caused without installing the toolbar. Here is the test case:

  1. In IE6, make sure script debugging/errors will show up.
  2. Go to  http://famostest.ourtoolbar.com.
  3. Click download toolbar and install it.
  4. After installation, you will be brought to  http://famostest.ourtoolbar.com/welcome/. You will see 3 error boxes (at least, there were three when I tried this) for a debug error on line 19 (now line 2741 by using the debug jquery). If you have debugger installed, click yes.
  5. Your debugger will highlight the text I mentioned in the bug report.
  6. My homepage is google.com. If you just restart IE6 the error occurs after (during?) the google page load. Sometimes, the error also occurs when you close the browser.

I have changed the toolbar to use the debug jquery file. The selected code when using this file is line 2741 (attached).

I have also attached the html page the conduit toolbar loads as a HTML component that causes the error (renamed to .txt so code can be seen).

Changed 5 years ago by bearp

HTML component code

Changed 5 years ago by bearp

Line 2741

comment:5 Changed 5 years ago by dmethvin

If the bug only occurs when the toolbar is installed, it is most likely caused by the toolbar. The toolbar might be doing an extra Release() on an IE object for example.

comment:6 Changed 5 years ago by dmethvin

  • Status changed from new to closed
  • Resolution set to invalid

Please follow the  bug reporting guidlines and use  jsFiddle when providing test cases and demonstrations instead of pasting the code in the ticket.

View

Add a comment

Modify Ticket

Action
as closed
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.