Bug Tracker

Ticket #4687 (closed bug: worksforme)

Opened 5 years ago

Last modified 17 months ago

Incorrect $(window).width() in Firefox

Reported by: dylan Owned by: brandon
Priority: major Milestone: 1.4
Component: dimensions Version: 1.3.2
Keywords: css width Cc:
Blocking: Blocked by:

Description

Firefox (tested: 3.0.10, Mac) reports the wrong value for $(window).width in really narrow browser windows. It gets stuck at a certain minimum, when the window width is obviously much less.

Reproduce:

  •  http://dyve.net/demo/jquery.width.html
  • Make your browser Window as narrow as possible
  • Note: no horizontal scrollbars
  • Press "click me" to see $(window).width() value
  • Repeat with Opera or Safari, sae window width, different (more accurate) results

Change History

comment:1 Changed 4 years ago by dmethvin

  • Status changed from new to closed
  • Resolution set to worksforme

Seems to report the correct width in Firefox 3.5 down to 116 pixels.

comment:2 Changed 4 years ago by dylan

Agreed, 3.6 works for me too.

comment:3 Changed 3 years ago by anonymous

Same problem occurring on FireFox 10.0.2 (Mac)

Seems to display a minimum of 400 pixels even when browser much narrower...

comment:4 Changed 2 years ago by anonymous

Seems to still be a problem in firefox mac. Min width 348 for me even when window is smaller. Firefox 15

comment:5 Changed 2 years ago by anonymous

I have the same issue in Firefox 11 - I get stuck at 502

comment:6 Changed 17 months ago by anonymous

... still on windows firefox 20

comment:7 Changed 17 months ago by dmethvin

None of you have provided a test case.

Note: See TracTickets for help on using tickets.