Bug Tracker

Modify

Ticket #4685 (closed bug: worksforme)

Opened 5 years ago

Last modified 3 years ago

Jumpy toggle() in Webkit when used on a div inside a table

Reported by: alex_sh Owned by:
Priority: major Milestone: 1.4
Component: effects Version: 1.3.2
Keywords: toggle show webkit jumpy Cc:
Blocking: Blocked by:

Description

When using toggle() (or show() / hide()) on a div inside a table, the whole thing is really jumpy in Webkit (tested with Safari 3.1.2 (windows) and Chrome).

This issue manifested itself in other browsers too (opera, FF), but I was able to fix it by manually specifying a size on the table cells. However, it does not help the jumpiness in Webkit-based browsers.

I'm attaching a test case where the problem is clearly demonstrated.

Attachments

jquery_toggle_webkit_bug.xhtml Download (1.6 KB) - added by alex_sh 5 years ago.
A test case

Change History

Changed 5 years ago by alex_sh

A test case

comment:1 Changed 4 years ago by dmethvin

  • Component changed from unfiled to fx

comment:2 Changed 3 years ago by addyosmani

  • Status changed from new to closed
  • Resolution set to worksforme

Thanks for submitting a ticket to the jQuery Bug Tracker!

I've reproduced your test case here  Live Test Case . From what I could tell, many of the reasons you were getting jumpiness in your code could be narrowed down to a lack of clear CSS definitions for both the table and divs that you were trying to use show/hide with. These have been fixed in the test case above and work fine across FF, Chrome, Safari and IE9.

If you continue to experience the issue feel free to let us know!

Please follow the  bug reporting guidlines and use  jsFiddle when providing test cases and demonstrations instead of pasting the code in the ticket.

View

Add a comment

Modify Ticket

Action
as closed
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.