Bug Tracker

Ticket #4665 (closed bug: duplicate)

Opened 6 years ago

Last modified 6 years ago

Chrome and Jquery Selector and Maximum size 49800 characters

Reported by: zzcyanide Owned by:
Priority: critical Milestone: 1.4
Component: unfiled Version: 1.3.2
Keywords: jquery selector, maximum size, chrome Cc:
Blocking: Blocked by:

Description

I am using ajax to return a content web page. The content happens to be greater than 49800 characters. IE and Firefox handle this with no problems, but in Chrome, it returns null.

Steps to reproduce:

  1. create a html content page with greater than 49800 characters.
  2. make a div with an identity you want to select, id="Title"
  3. load the page via ajax, and return the html content
  4. use a selector on the content to return the title:

function LoadContent( page ){

$.ajax

({

url: page ,cache: false ,success: function(html){ ContentLoaded(html); } ,error: function(httpObject, textStatus, errorThrown ) { alert( textStatus + " and " + errorThrown ); } ,dataType: "text" ,data:{} ,timeout:10000

});

} LoadContent

function ContentLoaded( html ){

var title = $("#Header", html).html(); alert( title );

}

This will throw an error in Chrome.

I am not sure if this is a maximum variable size limit in chrome or something something.

Doom on you Chrome!

Attachments

Chrome Issue.zip Download (47.1 KB) - added by zzcyanide 6 years ago.
chrome issue test files

Change History

Changed 6 years ago by zzcyanide

chrome issue test files

comment:1 Changed 6 years ago by dmethvin

  • Status changed from new to closed
  • Resolution set to duplicate

This is related to #3178 and most likely due to this (now-fixed) bug in Chrome/Safari:

 https://bugs.webkit.org/show_bug.cgi?id=14873

Note: See TracTickets for help on using tickets.