Bug Tracker

Modify

Ticket #4641 (closed bug: duplicate)

Opened 5 years ago

Last modified 3 years ago

Duplicates not removed before evaluating :eq(n)

Reported by: jeff_themovie Owned by: john
Priority: major Milestone:
Component: selector Version: 1.4.4
Keywords: Cc:
Blocking: Blocked by:

Description

The test suite has a selector test for "div div:eq(27)" but trying jQuery("div div").eq(27) in Firebug returns a different div.

I'd expect jQuery("div div:eq(27)") to return the same result as jQuery("div div").eq(27).

It seems that duplicates are not removed from the working list of elements before evaluating the :eq() selector (and I suspect other positional selectors as well, although I haven't tried those yet).

(The mailing list / discussion group thread is at  http://groups.google.com/group/jquery-dev/browse_thread/thread/fc49c5bc6524e8aa )

Attachments

testcase.html Download (1.6 KB) - added by jeff_themovie 5 years ago.
:eq(n) test case

Change History

Changed 5 years ago by jeff_themovie

:eq(n) test case

comment:1 Changed 4 years ago by john

  • Owner set to john
  • Component changed from unfilled to selector

comment:2 Changed 3 years ago by dmethvin

  • Status changed from new to open

comment:3 Changed 3 years ago by dmethvin

  • Version changed from 1.3.2 to 1.4.4
  • Milestone 1.4 deleted

comment:4 Changed 3 years ago by dmethvin

  • Status changed from open to closed
  • Resolution set to duplicate

comment:5 Changed 3 years ago by dmethvin

Duplicate of #7556.

Please follow the  bug reporting guidlines and use  jsFiddle when providing test cases and demonstrations instead of pasting the code in the ticket.

View

Add a comment

Modify Ticket

Action
as closed
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.