Bug Tracker

Ticket #4605 (closed bug: duplicate)

Opened 5 years ago

Last modified 5 years ago

Siblings (~) selector doesn't work right

Reported by: prokofyev Owned by: john
Priority: major Milestone: 1.4
Component: selector Version: 1.3.2
Keywords: Cc:
Blocking: Blocked by:

Description

$("#some_id ~ div") doesn't select DIV siblings if element with ID="some_id" is DIV itself.

$("#some_id ~ span") doesn't select SPAN siblings if element with ID="some_id" is SPAN itself.

Please, look for code sample here:  http://stackoverflow.com/questions/793687/cant-select-span-sibling

Thanks!

Change History

comment:1 Changed 5 years ago by jdalton

comment:3 Changed 5 years ago by john

  • Status changed from new to closed
  • Version set to 1.3.2
  • Resolution set to duplicate

Duplicate of #4243.

Note: See TracTickets for help on using tickets.