Bug Tracker

Modify

Ticket #4560 (closed bug: worksforme)

Opened 5 years ago

Last modified 3 years ago

.position().left incorrect in Chromium (possibly webkit)

Reported by: Anverc Owned by:
Priority: low Milestone: 1.next
Component: dimensions Version: 1.3.2
Keywords: Cc:
Blocking: Blocked by:

Description

Problem: Getting the position of a centered img element returns an incorrect .left in chrome (haven't tested other webkit browsers).

see  http://bennyland.com/test.html for a stripped down version of the bug I'm seeing (and then resize the window) for an example. You'll notice a red box show up once you resize the window - in IE and FF, this red box is centered over the top of the image, in Chrome, the red box is all the way to the left - this is because position().left is returning "10".

note: I was hopeful that  http://dev.jquery.com/ticket/4263 would solve the problem, however I implemented that changelist on a different (non stripped) test and the problem was still there.

note2: I've also attached a zip which contains the example files from bennyland.com

Attachments

test.zip Download (40.3 KB) - added by Anverc 5 years ago.

Change History

Changed 5 years ago by Anverc

comment:1 Changed 4 years ago by dmethvin

  • Component changed from unfiled to dimensions

comment:2 Changed 3 years ago by rwaldron

  • Priority changed from major to low
  • Status changed from new to open
  • Milestone changed from 1.4 to 1.4.5

Confirmed in Chrome 8 with 1.4.4-git, the image has:

left: 0px

but the correct value can be found in the computed styles as the margin-left value

comment:3 Changed 3 years ago by ajpiano

  • Status changed from open to closed
  • Resolution set to worksforme

This issue appears to be fixed in later versions of Chrome and Safari, even against jQuery 1.3.2. If this issue persists, please comment on this ticket with a reduced test case and we can investigate it further.

Please follow the  bug reporting guidlines and use  jsFiddle when providing test cases and demonstrations instead of pasting the code in the ticket.

View

Add a comment

Modify Ticket

Action
as closed
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.